View unanswered posts | View active topics It is currently Wed Apr 16, 2014 10:51 pm



Reply to topic  [ 211 posts ]  Go to page 1, 2, 3, 4, 5 ... 22  Next
 [HOW TO] Share Folders on Windows 7 with youtube tutorial 
Author Message

Joined: Tue Sep 08, 2009 10:41 am
Posts: 197
Location: Rotterdam, The Netherlands
Code:
Estimated Time:          10 min
Level:                   Average / Advanced
Operating System(s):     Windows 7
Category:                Networking
Firmware:                Tested with v7.06.r2388

On our Forums there have been a lot of problems with Shared Folders on Windows 7. We found out that one of the problems is that Windows 7 is not showing it's shared folders on the network by default. This HOW-TO describes how to make the changes necessary to share your folders over your network.

Let us first change your network and sharing settings:

  1. Press start menu and go to your Control Panel.
  2. Open your Network and Sharing Center.
  3. Click on the right on Change advanced sharing settings.
  4. Press the arrow at the right to hide your Home or Work profile.
  5. Then Press the arrow at the right to show your Public profile.
  6. Make the following changes:
    • Turn on network discovery.
    • Turn on file and printer sharing.
    • Turn off Public folder sharing.
    • Turn off password protected sharing.

Image

After these settings let’s take a look at your shared folder:

  1. Go to the folder you would like to share.
  2. Right click on the folder and select properties.
  3. Go to the tab ‘Sharing’.
  4. Press the button ‘Advanced Sharing’.
  5. Check the checkbox ‘Share this folder’.
  6. Now press the button ‘Permissions’.
  7. Click on the user ‘Everyone’
  8. If the user is not there please proceed to add the ‘Everyone’ user, if the user is there you can skip the following steps A to E.
    1. Press the ‘Add’ button.
    2. Press the ‘Advanced…’ button.
    3. Press the ‘Find Now’ button.
    4. Select the ‘Everyone’ user from the appearing list.

      Image

    5. Press ‘OK’ and in the next screen press ‘OK’ again.
  9. Give the ‘Everyone’ user at least permission to read this folder.

    Image

  10. You can now save all settings and close all windows.


You can now try again if your Playon!HD can access your Windows 7 share folders. If you get a username and password request you need to fill in here your username and password you use to login in Windows 7, if you have your guest account activated you can leave these fields blank and press OK.

If you are still having problems, after restarting, you can try the following steps.

Note: these steps are for advanced users, if you do not proceed exactly as described in the steps you can damage your register entries and you risk having to reinstall your Windows machine. Any of these changes are therefore on your own risk.

[edited by dirk]For those who do not want to open the registery file, here is a link to
download a file wich you have to run as a administrator ,
Download:
"PlayonHd.reg"
(with special thanks to MisterG)
the registery entries explained here next by Harro will then be changed automatically, you have to restart your windows after it is done to make them active.
[end edit by Dirk]



  1. Go to your Start Menu and press ‘Run’.
    • If you do not have Run in your start menu you can find the Run program in your Programs folder, then select Accessoires and select Run from that list.
  2. Type in ‘regedit’ and press OK.
  3. Search for the following location:
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\
  4. Double click on 'everyoneincludesanonymous' and change the value data to 1.

    Image

  5. Double click on ‘NoLmHash’ and change the value data to 0.

    Image

  6. Search for the following location:
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters\
  7. Double click on ‘restrictnullsessaccess’ and change the value data to 0.

    Image

  8. Close the register editor.
  9. Restart your PC.

[Update kraakie]
When you do both tweaks and restart your pc, you will see a workgroup in your ryan.
Select it and it will promp for a login . Just fill in nothing and choose add to my shortcuts.
After that if everything is ok it will login to your network and shows any shares.
Choose one of the shares and it will popup again to login.
Just fill in the user acount login data you specified in the share options of windows.
Like i have user test with password test has read rights on the d-disk.
This share is called d-drive. When i logon to the workgroup and select the D-drive share i login with user test and paswordt test. After that you will have acces to your shared hdd on your pc. If you don't have a HDD in your ryan the login data will not be saved !!!.
[End update kraakie]

Youtube movie on how to connect your playon!hd to your wwindows 7 shares

Done by Kraakie :)

http://www.youtube.com/watch?v=yRZKm0rq8Oc

If you are still having problems accessing your Windows 7 Shared Folders on your Playon!HD please reply to this topic. Outline your problem in detail and describe to us what steps you have been taken to solve the problem. Also provide us with detailed information about your network setup and the type of router you are using (if you are using any).

LAST NOTE: When using a dual-boot loader, for example Windows XP and Windows 7 on separated HDD's like I have, then you will experience some problems with your permissions in Windows XP after changing them in Windows 7. If you want to access them in Windows XP you first stop sharing your folder, apply setting and then Share the folder again. You can now access the permissions windows again.

_________________
NOTE: Please do not send me any PM or contact me on MSN. I do no longer work for AC Ryan, neither do I want to be associated with current AC Ryan management. Please contact AC Ryan support for your questions.


Sun Oct 18, 2009 9:10 pm
Profile

Joined: Tue Oct 13, 2009 1:00 pm
Posts: 4
Thanks for sharing.

Great efforts. I've been trying out for sometime and without success.

This will help me greatly.


Mon Oct 19, 2009 6:26 am
Profile

Joined: Thu Oct 15, 2009 9:32 am
Posts: 542
Location: Rotterdam, The Netherlands
Great way to support the Windows 7 users, as it soon will be surpassing the old XP and Vista. I'll give this a try sometime soon. ;)

Thanks Harro. :twisted:


Mon Oct 19, 2009 9:07 am
Profile

Joined: Tue Sep 08, 2009 10:41 am
Posts: 197
Location: Rotterdam, The Netherlands
Hi Guys,

No problem, let me know how it works out. Every situation is different so don't know if it works in all cases. Hope it does.

Cheers,

_________________
NOTE: Please do not send me any PM or contact me on MSN. I do no longer work for AC Ryan, neither do I want to be associated with current AC Ryan management. Please contact AC Ryan support for your questions.


Mon Oct 19, 2009 12:24 pm
Profile

Joined: Tue Sep 22, 2009 7:56 am
Posts: 11
Hi there
after try an error I used (have to, because there are no other Solutions in my mind *gg*)Harro´s Tut --->thx for that
an YES..it works...the Solution for me were the regkeys...
Using Win7 Ultimate 64 German Language since yesterday
Former Vista 64 and XP..there was no trouble with PlayON!HD and now there is no is none with Win7.
I think I´am an experienced PC User, but this was a damned piece of hard work *gg*


Tue Oct 20, 2009 10:07 am
Profile

Joined: Thu Oct 15, 2009 9:32 am
Posts: 542
Location: Rotterdam, The Netherlands
Good to see another problem that resolved itself. ;)


Tue Oct 20, 2009 11:09 am
Profile

Joined: Fri Oct 02, 2009 4:38 pm
Posts: 25
Yes ! It works for me on a Win 7 and a Win xp pro pc !

Thnx


Wed Oct 21, 2009 6:33 pm
Profile

Joined: Sat Sep 26, 2009 6:08 am
Posts: 828
Location: Seattle
Thank you. The registry key changes were the necessary fix for me as well. I am using Windows 7 Professional x64 with no login password on a single account and without those changes I could not get access.

I did not have any Homegroups either.

I do have to enter null and null when promted for net name but then login is successfull.
On XP Pro the login was automatic with no prompting. Must be another security layer built into Windows 7.


Thanks again,

Matt.

_________________
Playon!HD Firmware v7.06.r4107 (6/4/2010)
Internal SAMSUNG EcoGreen F2 HD103SI 1TB 5400 RPM
Windows 7x64 to Playon!HD Syncing done by Syncback (Free) over Ethernet via WRT54g (DD-WRT)
AVR(AVR130) <-SPDIF <- PlayOn!HD -> HDMI -> TV(TH-42pz700u)


Tue Oct 27, 2009 8:57 am
Profile

Joined: Sat Oct 24, 2009 6:29 pm
Posts: 8847
Location: Netherlands
After the tweak i dont have to put in anything when i connect to the pc in the workgroup it prompts login blabla i put in nothing

Then i browse to a share and it prompts again to login i fill in the usernaam en password that had read rights on that share

Works fine :)

_________________
Image
A.C. Ryan products now Available in Europe
http://www.mathilda-electronics.eu
Blog: http://acryanfaq.blogspot.com


Tue Oct 27, 2009 11:24 pm
Profile WWW

Joined: Sun Oct 18, 2009 9:39 pm
Posts: 372
Location: Malta GC (GMT+01.00)
Excellent! The registry changes sorted it.

Thanks.

_________________
PlayOn!HD + Samsung HD103SJ 1TB
via HDMI to Onkyo TX-SR608 to Samsung LE52A756


Wed Oct 28, 2009 11:57 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 211 posts ]  Go to page 1, 2, 3, 4, 5 ... 22  Next

Who is online

Users browsing this forum: FAST Enterprise [Crawler] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by: phpBB | Innitial forum Design by: STSoftware | Modified by: AC Ryan.