View unanswered posts | View active topics It is currently Tue Jul 22, 2014 2:23 pm



Reply to topic  [ 70 posts ]  Go to page 1, 2, 3, 4, 5 ... 7  Next
 HOWTO: Let the Media Library Index a mounted NAS share 
Author Message

Joined: Sat Dec 18, 2010 2:37 pm
Posts: 6
Hello all,
The procedure below is copied from the mini1 forum. It does not seem to work on the mini2.
I can successfully mount some shares from my NAS to an attachted usb-pendrive.
But the media library does not update. It seems to make a difference between 'real files' on the usb-drive and the mounted shares.

Can anyone tell me if this is expected behaviour, or has anyone succeeded getting the library to update with files on a mounted filesystem on a usb-drive on the mini2?

thanks, Richard

Quote:
How to Make the Media Library Index Files on a NAS
By default the POHD Mini’s Media Library section of the GUI will only catalogue files stored on a local hard drive – i.e. a USB disk or memory stick. To make the Media Library ‘see’ the files stored on a NAS, the trick is to create empty directories on the USB drive, to use as volume mount points, and mount the NAS shares onto them by editing the startup script.

Skills Needed
-Ability to use Telnet to connect to a Linux box, as the Mini uses an embedded version of Linux
-Ability to use vi to edit text files on a Linux operating system

Configuration of the USB Memory Stick
-Format on a PC – FAT32 is OK
-Create three directories in the root – Movies, Pictures and Music
-Insert into one of the sockets on the back of the mini and leave it there permanently

Modify the POHD Mini Startup Script
-Telnet to the Mini (username is root and no password) and cd to /user/local/etc.
-Edit rcS using vi - this is the mini's startup script.

at the end of the file add these lines- the mount commands are all on their own line

Sleep 30
mount -t cifs //192.168.1.73/Videos /mnt/usbmounts/sda1/Videos -o username=guest
mount -t cifs //192.168.1.73/Pictures /mnt/usbmounts/sda1/Pictures -o username=guest
mount -t cifs //192.168.1.73/Music /mnt/usbmounts/sda1/Music -o username=guest

-Remember Linux file / path names are case sensitive
-Restart the mini, and use the browser to browse to the USB drive, and then the subdirectories on the drive – you should see your content on the NAS

Update the Media Library
Each of the three sections of the Media Library need to be updated separately – they update their own table in a small SQLlite database. Once this update is done, the Media Library will have indexed all the NAS content – and it’s available for the searches available through the GUI


Last edited by magnolia61 on Sat Feb 19, 2011 8:51 am, edited 1 time in total.



Mon Feb 14, 2011 1:15 pm
Profile

Joined: Wed Feb 16, 2011 2:23 pm
Posts: 11
My Mini2 has just arrived today, and I was wondering why so many people seem to be going on about having to 'click' too many times to get to their network movies!
Now I see why! The SMB shares are not indexed by the Playon..

I hope they fix this with a firmware update, many of us have a large amount of media stored on NAS's or other servers etc, I don't want to take USB drives around the house just to make it easy to use!

I only need the Mini2 to replace an old Xbox that was running XBMC, which only did SD, so it's not that much of an issue to me at the moment, but I wanted to try one out, as I have a HTPC with MCE/Mediabrowser that I could replace with something much smaller/quieter and cheaper, but it absolutely would have to be easy to use etc..

Anyway, regarding the above, I'd just check that SDA1 is how the USB drive is mounted.. apart from the script not running at startup, I can't see how in a linux environment that it would fail.. I've sometimes put in comments that output to a text file in the script just to check it is actually running..


Wed Feb 16, 2011 2:44 pm
Profile

Joined: Wed Feb 16, 2011 10:45 pm
Posts: 63
Location: Czech Republic
Yes, me also, I have NAS 6TB server and I got mini just to be able to stream comfortly its content in my living room. This is something I really did not expect... I am not that much up to indexing all over and so, I am actually quite comfy with just fime browsng, BUT, why is the ID# taging not working? it does not show any information... it only says no id3tag...

_________________
PlayOn HD mini 2


Thu Feb 17, 2011 12:57 am
Profile ICQ

Joined: Wed Feb 16, 2011 2:23 pm
Posts: 11
I unboxed and spent a few hours with the Mini2 last night.

You can get it to mount your network shares on USB folders as per the example above..

However, you will need to tailor it to your exact setup..

For example, here's what I had to do
1. Setting the right username/password for my network shares..
I have a user setup for readonly access from my old Xbox, it's username and password where set both to 'xbox'.. so I had to change the "mount" command to..
Code:
mount -t cifs //192.168.1.2/Movies /mnt/usbmounts/sda1/Music -o username=xbox,password=xbox

2. Getting the timing right for my wireless dongle.
I had to 'sleep 60' to ensure that the wireless dongle was detected and connected to my network, or the mounts fail..


Some tests..
The way to 'test' it is to use PuTTy or similar to telnet to the mini2 and with your USB Stick in, check out two things
1. Ensure your USB Is mounting as /mnt/usbmounts/sda1
2. Ensure any folders you have created as mount points on the USB stick are as expected, e.g.
"cd /mnt/usbmounts/sda1", then "ls" and you should see your pre-created folders that the network shares will mount to, e.g. Movies, Music etc..

2. Manually try mounting a share using the "mount -t cifs......" command from the telnet console, if it works, it'll report no error, and actually you can then go to FileManager->USB->Movies as an example and you will see all your files on that network share.. once you know it's working manually, you can put it at the end of your /usr/local/etc/rcS file.


If you don't know how to use vi to edit files in linux, and I didn't!, it's not too bad if you stick to the basics..

just do the following
"cd /usr/local/etc"
"vi rcS"

then once in vi, you can use the arrow keys to move around the document, when you want to edit, you can just press 'i' (You'll notice bottom right, the I symbol appears to show you are inserting/editing).
Whilst in this mode, you can add/remove whatever text you want, the delete key didn't work for me, I had to go back into editing mode by pressing 'i' again.. but backspace was fine..
Once the file looks right, hit ESC twice, the screen will flash slightly, then type :wq to Save and Quit..

Reboot your box (Put it into standby and then back out), and it should mount your shares fine..


What I can't do is trigger the media library to index it after I've mounted the network shares, especially using a wireless dongle, as the media scanning is done before the wireless is up and running.. If I could figure out how to trigger a scan, I could just append that to the rcS file..


Thu Feb 17, 2011 10:48 am
Profile

Joined: Wed Feb 16, 2011 10:45 pm
Posts: 63
Location: Czech Republic
Well I think it is due tou the 60s sleep you put down, I played a bit last night also, and I figured out that adding the lins in rcS script didnt work with 30s, so what I basicly did was telneting to my playon right after starting and immediatly after logon promt I loged in and mounted the network shares to the USB flash card folders... this was before the gui fully came up on the screen, when it came up it tried tu scan my flash card and started indexing whole NAS content... Unfortunatelly it freez few times during it and did not finishe the indexing but I was able to see some of the indexed pictures I have in my photo library... Well I was just not sure wht would be the right way to automount the network shares since 30s seams to be too low and 60 is too much, so I think we should just ask A.C Ryan to implement network indexing and scaning, coz I think most people will buy the HD mini 2 exactely for the network streaming porpouse, since it has 1Gb Eth. and has the power to play most of present media files...

_________________
PlayOn HD mini 2


Thu Feb 17, 2011 1:58 pm
Profile ICQ

Joined: Wed Feb 16, 2011 2:23 pm
Posts: 11
Using an wired LAN setup, 30s worked fine for me, although it still didn't scan the files as it was after the automount trigger to scan the USB device..

It was only wireless that really only connects much later in the process did I just try 60s as a 'definitely' will be connected by then!

Regarding scanning, this really needs to be programmatically handled, i.e. see if I can find what is being run when a USB automounts, and just run that after my script..

I do agree that ACRyan really should work on the fundamentals of the interface, as a software engineer myself, we are asking for simple things here, and lets face it, you don't need too much functionality to cater for most people..

Lets see,

All I'd want is to be able to define and add my own icons on the home page, I'd have MOVIES, TV, PHOTOs, MUSIC, but give people the option of more, each icon then can be assigned to one or more sources (aggregate the media from more then 1 place under each one), or point to the index.html in a jukebox fashion,

For example, the homepage has a list of icons, you can add/edit/delete these, and they just have the options
"Label" - i.e. text displayed on the homepage
"Icon" - o.e. icon displayed on the homepage
"Source Type" - Folders or File (to support selecting a single file such as an index.html, then suboptions,
---"Sources" - A list of sources, network share, local folder (Aggregates all media found)
---"File" - a single network/local file to 'run', e.g. point it at index.html, or if flash is supported, a .swf ?
"Display types" - i.e "Music files", "Movie Files", "Photo's", "all" etc to hide unwanted files from that view
"Default view type" - "Folder", "library", etc
"Default view style" - "List", "Thumbnails", etc

Then get rid of the Jukebox and setup icons (Jukebox is covered by the above, the setup has it's own button on the remote!)..

Once that's done, they can work on a slicker front end using flash or something (I believe the 1085 has a flash enabled browser support)..

If only life was so easy ;)


Thu Feb 17, 2011 3:50 pm
Profile

Joined: Wed Feb 16, 2011 10:45 pm
Posts: 63
Location: Czech Republic
Exactly, I think there was not really much effort to hink about comfort of using this device... If there was a single beta tester who would really like to use this as his home media streamer I think there would be much of our wishes solved already... Next to just NAS access and browsing all the little thing my 10years old iRiver portable H120 juckebox with open source firmware (rockbox) can do. Gapless playback of music, flac support for all supported audio files atc...

This is really embarressing that I have more comfort for music playback on my vintage portable player then in present time sold so called "cutting edge" devices, which has enoug power to count scientific patterns but has really unfinished software... Well, I think this is something what would really work as a magnet for custommers, just let people know that the product has great support and people who work on it know why they do what they do and not such things like all the time shining red light without possibelity to turn it of, advertising support of something what at the end does not work and listing of files without much sense... I would be really happy for even a bit unstable device at first if it had fast and reasonable support than something what comes without user manual because of dead lines... damn this is not way to go guys...

_________________
PlayOn HD mini 2


Thu Feb 17, 2011 5:04 pm
Profile ICQ

Joined: Sat Dec 18, 2010 2:37 pm
Posts: 6
Hello people,
I think I have succeeded in achieving just what I wanted:
To have the mini2 index my shares from my NAS that I mounted on a usb-drive.

Here is my specific how-to.

In /usr/local/etc I created a file named: mountnas with the following contents:
Code:
#!/bin/sh
sleep 20
ip=10.0.0.3
expt1=media/Music/M61-LIBRARY
mntp=/usr/local/etc
mkdir $mntp/Music
options=nolock,proto=tcp
mount -t nfs -o $options $ip:/$expt1 $mntp/Music
mount -o bind $mntp/Music /tmp/usbmounts/sda4/Music

and in /usr/local/rcS i added the line:
Code:
/usr/local/etc/mountnas &

my trick seems to be to first mount the shares in /usr/local/etc
and to bind them to /tmp/usbmounts afterwards.
Also i reduced the sleep to 20 in my hardwired lan-situation.
In my config my usb-stick is sda4. This can be a different # in your situation.

RESULT: my mini2 now indexes my NAS!


Last edited by magnolia61 on Sat Feb 19, 2011 8:50 am, edited 1 time in total.



Fri Feb 18, 2011 7:33 pm
Profile

Joined: Mon Feb 14, 2011 4:07 pm
Posts: 21
blime! :) I gotta try this...


Fri Feb 18, 2011 8:35 pm
Profile

Joined: Wed Feb 16, 2011 10:45 pm
Posts: 63
Location: Czech Republic
Thanx magnolia61, I am going to try this right away... thank you for the post... this really did not came up to my mind as possible sollution...

Will report my experiance... Will try mount cifs instead of nas, since I am experiancing some other strange issue with NFS mounting to this small box...

_________________
PlayOn HD mini 2


Sat Feb 19, 2011 12:37 am
Profile ICQ
Display posts from previous:  Sort by  
Reply to topic   [ 70 posts ]  Go to page 1, 2, 3, 4, 5 ... 7  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by: phpBB | Innitial forum Design by: STSoftware | Modified by: AC Ryan.